请选择 进入手机版 | 继续访问电脑版
查看: 129|回复: 1

[工具专区] Pacu:功能强大的AWS漏洞利用框架

[复制链接]
  • TA的每日心情

    7 小时前
  • 签到天数: 693 天

    [LV.9]以坛为家II

    发表于 2018-12-6 18:15:02 | 显示全部楼层 |阅读模式
    本帖最后由 90_ 于 2018-12-6 18:18 编辑



        在Pacu的帮助下,测试人员可以利用AWS账号中的错误配置漏洞,而且可以通过使用模块的方式来扩展工具的功能。当前的模块支持大量常见的攻击场景,包括用户提权、IAM用户植入后门以及攻击存在安全缺陷的Lambda函数等等。

    工具安装
      Pacu是一款轻量级工具,它要求使用Python 3.5+,并需要通过pip3来安装其他Python库。运行install.sh之后,脚本会检查你的Python版本,并确保所有的Python包都是最新版本。

    快速安装

    [AppleScript] 纯文本查看 复制代码
    git clone [url]https://github.com/RhinoSecurityLabs/pacu[/url]
    
    cd pacu
    
    bash install.sh
    
    python3 pacu.py


    具体的安装指令,请参考【安装指引】。

    工具使用

    Pacu首次启动之后,工具将提示用户开启和命名新的会话。这个会话将用来存储AWS密钥对,以及其他通过运行模块收集到的数据。你可以在Pacu中开启各种不同的会话,每一个会话都拥有各自对应的AWS密钥对以及数据集。

    模块的使用同样需要AWS密钥,这个密钥会给你提供AWS环境的访问权。如果你在使用中遇到了困难。可以使用help命令来查看可用命令的列表。

    Pacu的基础命令
    [AppleScript] 纯文本查看 复制代码
    >list:该命令可以列举出所有可用的模块;
    
    >helpmodule_name:该命令将返回特定模块的帮助信息;
    
    >runmodule_name:该命令可以配合特定的参数来运行指定的模块;
    
    > runmodule_name –regions eu-west-1、us-west-1:该命令将针对eu-west-1和us-west-1这两个区域运行指定模块;


    注意事项
    1、 Pacu目前仅支持macOS和Linux环境。

    2、 Pacu是一款开源软件,遵循BSD-3-Clause许可证协议。

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?注册

    x
    回复

    使用道具 举报

  • TA的每日心情
    开心
    昨天 12:18
  • 签到天数: 16 天

    [LV.4]偶尔看看III

    发表于 2018-12-7 16:45:01 | 显示全部楼层
    沙发沙发
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 注册

    本版积分规则

    快速回复 返回顶部 返回列表